<!DOCTYPE html>
<html lang="en-US">
<head>
<meta http-equiv="X-UA-Compatible" content="IE=9">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>A Data Science Lesson from Richard Feynman | Mic Farris</title>
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.micfarris.com/xmlrpc.php">
<!--[if lt IE 9]><script src="http://www.micfarris.com/wp-content/themes/getnoticed/js/html5.js" type="text/javascript"></script><![endif]-->

<!-- All in One SEO Pack 2.3.15.3 by Michael Torbert of Semper Fi Web Design[188,250] -->
<meta name="description"  content="Data Science can learn a bit from the great scientist Richard Feynman about the importance of seeking understanding in science and in understanding the world." />

<meta name="keywords"  content="richard feynman,data science" />

<link rel="canonical" href="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mic Farris &raquo; Feed" href="http://www.micfarris.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mic Farris &raquo; Comments Feed" href="http://www.micfarris.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mic Farris &raquo; A Data Science Lesson from Richard Feynman Comments Feed" href="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.micfarris.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='crp-style-rounded-thumbs-css'  href='http://www.micfarris.com/wp-content/plugins/contextual-related-posts/css/default-style.css?ver=4.8.1' type='text/css' media='all' />
<style id='crp-style-rounded-thumbs-inline-css' type='text/css'>

.crp_related a {
  width: 50px;
  height: 50px;
  text-decoration: none;
}
.crp_related img {
  max-width: 50px;
  margin: auto;
}
.crp_related .crp_title {
  width: 50px;
}
                
</style>
<link rel='stylesheet' id='style-css'  href='http://www.micfarris.com/wp-content/themes/getnoticed/style.css?ver=20131025' type='text/css' media='all' />
<link rel='stylesheet' id='custom-css'  href='http://www.micfarris.com/wp-content/themes/getnoticed/style-custom.css?ver=20131018' type='text/css' media='all' />
<link rel='stylesheet' id='print-css'  href='http://www.micfarris.com/wp-content/themes/getnoticed/style-print.css?ver=20130731' type='text/css' media='print' />
<link rel='stylesheet' id='responsive-css'  href='http://www.micfarris.com/wp-content/themes/getnoticed/style-responsive.css?ver=20131018' type='text/css' media='screen' />
<link rel='stylesheet' id='wp_greet_box_style-css'  href='http://www.micfarris.com/wp-content/plugins/wp-greet-box/css/style.css?ver=4.8.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.micfarris.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.micfarris.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.micfarris.com/wp-content/plugins/gravatar-signup/jquery.md5.pack.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://www.micfarris.com/wp-content/plugins/wp-greet-box/js/functions.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://www.micfarris.com/wp-content/plugins/wp-greet-box/js/js-mode.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='http://www.micfarris.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.micfarris.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.micfarris.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='10 Things To Know When Hiring Data Scientists' href='http://www.micfarris.com/2013/09/10-things-to-know-when-hiring-data-scientists/' />
<link rel='next' title='The Fundamentals of Data Science' href='http://www.micfarris.com/2014/10/the-fundamentals-of-data-science/' />

<link rel='shortlink' href='http://www.micfarris.com/?p=1433' />
<link rel="alternate" type="application/json+oembed" href="http://www.micfarris.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.micfarris.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F&#038;format=xml" />

<!-- Bad Behavior 2.2.19 run time: 3.584 ms -->
<script type="text/javascript">
<!--
function bb2_addLoadEvent(func) {
	var oldonload = window.onload;
	if (typeof window.onload != 'function') {
		window.onload = func;
	} else {
		window.onload = function() {
			oldonload();
			func();
		}
	}
}

bb2_addLoadEvent(function() {
	for ( i=0; i < document.forms.length; i++ ) {
		if (document.forms[i].method == 'post') {
			var myElement = document.createElement('input');
			myElement.setAttribute('type', 'hidden');
			myElement.name = 'bb2_screener_';
			myElement.value = '1502754144 54.224.77.253';
			document.forms[i].appendChild(myElement);
		}
	}
});
// --></script>
		<link rel="author" href="https://plus.google.com/113190000896646425022/posts"/>
<script type="text/javascript">
jQuery(document).ready(function(b){function a(c){return"http://www.gravatar.com/avatar/"+b.md5(c)}b("#email").blur(function(){var e="48";var d=b(this).val().toLowerCase();if(d.indexOf("@")==-1){return}var c=new Image();b(c).load(function(){b("#ajax_get_avatar").hide()}).error(function(){b("#ajax_get_avatar").html('<input style="width:auto;" name="get_gravatar" id="get_gravatar" value="1" type="checkbox" /> <label for="get_gravatar">Sign me up for a free Gravatar image to appear next to my comments</label>').show()}).attr("src",a(d)+"?s="+e+"&d=404")});b("#email").trigger("blur")});
</script>
<!-- Get Noticed! Open Graph -->
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:site" content="@MicFarris" />
	<meta name="twitter:creator" content="@MicFarris" />
	<meta property="og:title" content="A Data Science Lesson from Richard Feynman" />
	<meta property="og:type" content="article" />
	<meta property="og:url" content="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" />
	<meta property="og:site_name" content="Mic Farris" />
	<meta property="og:image" content="http://www.micfarris.com/wp-content/uploads/2014/02/pleasure.jpg" />
	<meta property="og:description" content="Data Science can learn a bit from the great scientist Richard Feynman about the importance of seeking understanding in science and in understanding the world." />
<!-- / Get Noticed! Open Graph -->
<style type="text/css" id="getnoticed_generated_styles">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</style><link rel="icon" href="http://www.micfarris.com/wp-content/uploads/2011/11/cropped-supreme-court-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://www.micfarris.com/wp-content/uploads/2011/11/cropped-supreme-court-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.micfarris.com/wp-content/uploads/2011/11/cropped-supreme-court-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://www.micfarris.com/wp-content/uploads/2011/11/cropped-supreme-court-270x270.jpg" />
			<script type="text/javascript">
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-4259752-5']);
								_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
		<!--[if lt IE 9]><link rel="stylesheet" href="http://www.micfarris.com/wp-content/themes/getnoticed/style-ie8.css" type="text/css" charset="utf-8" /><![endif]-->
</head>
<body class="post-template-default single single-post postid-1433 single-format-standard">
<div class="sitewrap">
	
	
	<nav id="headernav" role="navigation" class="site-navigation main-navigation"><div class="innerwrap">
		<h2 class="mobile-title"><a href="http://www.micfarris.com/" title="Mic Farris" rel="home">Mic Farris</a></h2>
			<h1 class="assistive-text">Menu</h1>
	<div class="assistive-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>

		<div id="primary-menu">
					</div>
			<div class="social">
		<ul>
		<li><a class="twitter" href="http://twitter.com/MicFarris" onclick="_gaq.push(['_trackPageview', '/outbound/social/header/']);" target="_blank"><i></i>Follow me on Twitter</a></li><li><a class="facebook" href="http://www.facebook.com/micfarris" onclick="_gaq.push(['_trackPageview', '/outbound/social/header/']);" target="_blank"><i></i>Like me on Facebook</a></li><li><a class="linkedin" href="http://www.linkedin.com/in/micfarris" onclick="_gaq.push(['_trackPageview', '/outbound/social/header/']);" target="_blank"><i></i>Connect with me on LinkedIn</a></li>		</ul>
	</div>
			<div class="mobile_actions">
			<a class="mobile_menu" href="#menu">menu</a>
			<div id="mobile_search"></div>
		</div>

	</div></nav>
	
<div id="page" class="hfeed site wrap">
			<header id="masthead" class="site-header" role="banner"><div class="innerwrap">

				

		<hgroup>
			<h1 class="site-title"><a href="http://www.micfarris.com/" title="Mic Farris" rel="home">Mic Farris</a></h1>
			<h2 class="site-description">Decisions &amp; Discovery</h2>
		</hgroup>

		
		<div class="headshot"></div>

				
	</div></header><!-- #masthead .site-header -->
	
	
	<div id="main"><div class="innerwrap">
		
				<aside id="top_search" class="widget widget_search"><div class="content">
				<div id="searchform"><form method="get" action="http://www.micfarris.com/" role="search">
		<label for="s" class="assistive-text">Search</label>
		<input type="text" class="field" name="s" id="s" placeholder="Search my blog&hellip;"><!--
		--><input type="submit" class="submit" name="submit" id="searchsubmit" value="Search">
	</form></div>
		</div></aside>
	
		<div id="primary" class="site-content">
			<div id="content" role="main">

			
					<nav role="navigation" id="nav-above" class="site-navigation post-navigation">
		<h1 class="assistive-text">Post navigation</h1>

	
		<div class="nav-previous"> <a href="http://www.micfarris.com/2013/09/10-things-to-know-when-hiring-data-scientists/" rel="prev"> <span class="meta-nav">&#11013;</span>  10 Things To Know When Hiring Data...  </a></div>		<div class="nav-next"><a href="http://www.micfarris.com/2014/10/the-fundamentals-of-data-science/" rel="next">The Fundamentals of Data Science <span class="meta-nav">&#10145;</span></a></div>
	
	</nav><!-- #nav-above -->
	
				<article id="post-1433" class=" introfeature post-1433 post type-post status-publish format-standard has-post-thumbnail hentry category-data-science category-more-science tag-data-science-2 tag-richard-feynman">
	<header class="entry-header">
				<div class="entry-meta">
					</div><!-- .entry-meta -->
		
		<h1 class="entry-title">A Data Science Lesson from Richard Feynman</h1>

				
	</header><!-- .entry-header -->

	<aside class='sharebar'>
<span class="share-comment"><a href="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/#respond" title="Comment on this Post" class="button">Comment</a><span class="count-effect"><span class="count-wrap"><i class="spa"></i><i class="spb"></i><span class="count">1</span></span></span></span>
<span class='sep'> | </span>
<span class="share-social share-facebook"><a href="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F" class="button" title="Share on Facebook" data-url="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" target="_blank" rel="nofollow"><i></i><span>Share</span></a><span class="count"></span></span>
<span class='sep'> | </span>
<span class="share-social share-tweet"><a href="https://twitter.com/intent/tweet?original_referer=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F&source=tweetbutton&text=A+Data+Science+Lesson+from+Richard+Feynman&url=http%3A%2F%2Fwww.micfarris.com%2F%3Fp%3D1433&via=MicFarris" class="button" title="Tweet this Post" data-url="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" target="_blank" rel="nofollow"><i></i><span>Tweet</span></a><span class="count"></span></span>
<span class='sep'> | </span>
<span class="share-social share-linkedin"><a href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F&title=A+Data+Science+Lesson+from+Richard+Feynman&source=Get+Noticed%21+Theme" class="button" title="Share on LinkedIn" data-url="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" target="_blank" rel="nofollow"><i></i><span>Share</span></a><span class="count"></span></span>
<span class='sep'> | </span>
<span class="share-social share-googleplus"><a href="https://plus.google.com/share?hl=en-US&url=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F" class="button" title="Share on Google+" data-url="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" target="_blank" rel="nofollow"><i></i><span>+1</span></a></span>
<span class='sep'> | </span>
<span class="share-print"><a href="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/#print" class="button"><span>print</span></a></span>
<span class='sep'> | </span>
<span class="share-email"><a href="mailto:?subject=A%20Data%20Science%20Lesson%20from%20Richard%20Feynman&amp;body=Hey%2C%0D%0A%0D%0AI%20wanted%20to%20share%20this%20post%20by%20Mic%20Farris%20with%20you.%0D%0A%0D%0Ahttp%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F%0D%0A%0D%0AThanks%21" class="button"><span>email</span></a></span></aside>
	
	<div class="entry-content">
		<div id="greet_block"><noscript><div class="greet_block wpgb_cornered"><div class="greet_text"><div class="greet_image"><a href="http://www.micfarris.com/feed/rss/"  rel="nofollow"><img src="http://www.micfarris.com/wp-content/plugins/wp-greet-box/images/rss_icon.png" alt="WP Greet Box icon"/></a></div>Hello there! If you are new here, you might want to <a href="http://www.micfarris.com/feed/rss/" rel="nofollow"><strong>subscribe to the RSS feed</strong></a> for updates on this topic.<div style="clear:both"></div><div class="greet_block_powered_by">Powered by <a href="http://omninoggin.com/projects/wordpress-plugins/wp-greet-box-wordpress-plugin/" title="WP Greet Box WordPress Plugin" style="text-decoration:none;">WP Greet Box</a> <a href="http://omninoggin.com/" title="WordPress Plugin" style="text-decoration:none;">WordPress Plugin</a></div><div style="clear:both"></div></div></div></noscript></div><div>
<div id="attachment_1434" style="width: 220px" class="wp-caption alignleft"><a href="http://www.micfarris.com/wp-content/uploads/2014/02/pleasure.jpg"><img class="size-full wp-image-1434" alt="Richard Feynman" src="http://www.micfarris.com/wp-content/uploads/2014/02/pleasure.jpg" width="210" height="320" srcset="http://www.micfarris.com/wp-content/uploads/2014/02/pleasure.jpg 210w, http://www.micfarris.com/wp-content/uploads/2014/02/pleasure-196x300.jpg 196w, http://www.micfarris.com/wp-content/uploads/2014/02/pleasure-82x124.jpg 82w" sizes="(max-width: 210px) 100vw, 210px" /></a><p class="wp-caption-text">Richard Feynman</p></div>
<p class="first-child "><span title="R" class="dropcap">R</span>ichard Feynman is one of the greatest scientific minds, and what I love about him, aside from his brilliance, is his perspective on why we perform science.   I’ve been reading the compilation of short works of Feynman titled <em><a title="The Pleasure of Finding Things Out: The Best Short Works of Richard P. Feynman" href="http://www.amazon.com/Pleasure-Finding-Things-Out-Richard/dp/0465023959/ref=sr_1_1?s=books&ie=UTF8&qid=1391987899&sr=1-1&keywords=the+pleasure+of+finding+things+out" target="_blank">The Pleasure of Finding Things Out</a></em>, and I recently came across a section that really hit home with me.</p>
</div>
<div>In the world of <a title="Data Science Defined - Mic Farris" href="http://www.micfarris.com/2011/09/data-science-defined/" target="_blank">data science</a>, much is made about the algorithms used to work with data, such as <a title="Random Forest - Wikipedia" href="http://en.wikipedia.org/wiki/Random_forest" target="_blank">random forests</a> or <a title="K-means Clustering - Wikipedia" href="http://en.wikipedia.org/wiki/K-means_clustering" target="_blank">k-mean clustering</a>.  However, I believe there is a missing component – one that deals the fundamentals underlying data science, and that is the real <em>science</em> of data science.</div>
<div></div>
<p><span id="more-1433"></span></p>
<div>The following paragraphs are taken from <em><a title="The Pleasure of Finding Things Out: The Best Short Works of Richard P. Feynman" href="http://www.amazon.com/Pleasure-Finding-Things-Out-Richard/dp/0465023959/ref=sr_1_1?s=books&ie=UTF8&qid=1391987899&sr=1-1&keywords=the+pleasure+of+finding+things+out" target="_blank">The Pleasure of Finding Things Out</a></em>, which I would encourage you all to read.  Feynman’s way of cutting through the scientific and mathematical gobbledygook to get to the essence of what all that stuff represents is remarkable, which in my mind just demonstrates his brilliance since he’s so able to communicate what he knows to other people.  I’ve written on the importance of effective communication, especially in science – the most effective scientific communicators were <a title="Why Scientists Are Lousy Communicators" href="http://www.micfarris.com/2010/03/why-scientists-are-lousy-communicators/" target="_blank">Albert Einstein</a> and <a title="What We Can Learn From Stephen Hawking (Besides the Mysteries of Black Holes)" href="http://www.micfarris.com/2009/05/what-we-can-learn-from-stephen-hawking-besides-the-mysteries-of-black-holes/" target="_blank">Stephen Hawking</a>; I would definitely put Richard Feynman in that class.</div>
<div></div>
</p>
<div><em>One way, that’s kind of a fun analogy in trying to get some idea of what we’re doing in trying to understand nature, is to imagine that the gods are playing some great game like chess, let’s say, and you don’t know the rules of the game, but you’re allowed to look at the board, at least from time to time, in a little corner, perhaps, and from these observations you try to figure out what the rules of the game are, what the rules of the pieces moving are. You might discover after a bit, for example, that when there’s only one bishop around on the board that the bishop maintains its color. Later on you might discover the law for the bishop as it moves on the diagonal which would explain the law that you understood before – that it maintained its color – and that would be analogous to discovering one law and then later finding a deeper understanding of it. Then things can happen, everything’s going good, you’ve got all the laws, it looks very good, and then all of a sudden some strange phenomenon occurs in some corner, so you being to investigate that – it’s castling, some thing you didn’t expect. We’re always, by the way in fundamental physics, always trying to investigate those things in which we don’t understand the conclusions. After we’ve checked them enough, we’re okay.</em></div>
<div></div>
</p>
<div><em>The thing that doesn’t fit is the thing that’s the most interesting, the part that doesn’t go according to what you expected. Also, we could have revolutions in physics: after you’ve noticed that the bishops maintain their color and they go along the diagonal and so on for such a long time and everybody knows that that’s true, then you suddenly discover one day in some chess game that the bishop doesn’t maintain its color, it changes its color. Only later do you discover a new possibility, that a bishop is captured and that a pawn went all the way down to the queen’s end to produce a new bishop – that can happen but you didn’t know it, and so it’s very analogous to the way our laws are: They sometimes look positive, they keep on working and all of a sudden some little gimmick shows that they’re wrong and then we have to investigate the conditions under which this bishop change of color happened and so forth, and gradually learn the new rule that explains it more deeply. Unlike the chess game, though, in [which] the rules become more complicated as you go along, in physics, when you discover new things, it look more simple. It appears on the whole to be more complicated because we learn about a greater experience – that is, we learn about more particles and new things – and so the laws look complicated again. But if you realize all the time what’s kind of wonderful – that is, if we expand our experience into wilder and wilder regions of experience – every once in a while we have these integrations when everything’s pulled together into a unification, in which it turns out to be simpler than it looked before.</em></div>
<div></div>
</p>
<div><em>If you are interested in the ultimate character of the physical world, or the complete world, and at the present time our only way to understand that is through a mathematical type of reasoning, then I don’t think a person can fully appreciate, or in fact can appreciate much of, these particular aspects of the world, the great depth of character of the universally of the laws, the relationships of things, without an understanding of mathematics. I don’t know any other way to do it, we don’t know any other way to describe it accurately… or to see the interrelationships without it. So I don’t think a person who hasn’t developed some mathematical sense is capable of fully appreciating this aspect of the world – don’t misunderstand me, there are many, many aspects of the world that mathematics is unnecessary for, such as love, which are very delightful and wonderful to appreciate and to feel awed and mysterious about; and I don’t mean to say that the only thing in the world is physics, but you were talking about physics and if that’s what you’re talking about, then to not know mathematics is a server limitation in understanding the world.</em></div>
<div></div>
</p>
<div>The connection here to data science is the search for understanding.  Research and engineering teams use data science to explain things about the data, so that we can use that information later – maybe to make predictions, maybe for better explanations, maybe to make better products.  However, the key part is <span style="text-decoration: underline;">the understanding</span> and without that, data science is merely a collection of tools and techniques used to fit observations.  Unless we seek to understand – trying the find “the why” – then we won’t really know whether our data science models, tools, or techniques are actually working.</div>
<div></div>
</p>
<div>If you are interested, these passages are from a <a title="Feynman :: Rules of Chess" href="http://www.youtube.com/watch?v=o1dgrvlWML4" target="_blank">television interview</a> Feynman conducted as part of a BBC documentary<em> Richard Feynman: No Ordinary Genius.</em></div>
<div><!--more--></div>
<div></div>
</p>
<div><em><strong>Question:  Do you have any thoughts on the fundamental science of data science or on Richard Feynman? You can leave a comment below.</strong></em></div></p>
<div class="crp_related "><h3>Related Posts:</h3><ul><li><a href="http://www.micfarris.com/2014/10/the-fundamentals-of-data-science/"    ><span class="crp_title">The Fundamentals of Data Science</span></a></li></ul><div class="crp_clear"></div></div>	</div>

	<div class="authorbox"><div class="authorbox-side"><img alt='' src='http://0.gravatar.com/avatar/081d4c295b64c87e3a0cc3420dc6c11b?s=100&#038;d=retro&#038;r=g' srcset='http://0.gravatar.com/avatar/081d4c295b64c87e3a0cc3420dc6c11b?s=200&amp;d=retro&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><ul class="getnoticed-social"><li><a class="authorbox-social website" href="http://www.micfarris.com"><i></i>Website</a></li></ul></div><div class="authorbox-main"><h3 class="authorbox-name"><span class="author vcard"><a class="url fn n" href="http://www.micfarris.com/author/admin/" title="View all posts by Mic Farris" rel="author">Mic Farris</a></span></h3><div class="authorbox-bio"><p>I currently serve as Director in the Advanced Risk &amp; Compliance Analytics (ARCA) practice at PricewaterhouseCoopers (PwC).  I've served as Director of Data Science &amp; Analytics Engineering at Areté Associates and in leadership positions with Elanix, Inc. (now Agilent Technologies) and Mentor Graphics.  I've served the public as Chair of the Thousand Oaks, CA Planning Commission and now work in New York City.  I have been married to my wife Stephanie since 1993, and we have a wonderful daughter Monroe.  <a href="http://www.micfarris.com/about">Learn more about me »</a></p>
</div></div></div><aside class='sharebar'>
<span class="share-comment"><a href="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/#respond" title="Comment on this Post" class="button">Comment</a><span class="count-effect"><span class="count-wrap"><i class="spa"></i><i class="spb"></i><span class="count">1</span></span></span></span>
<span class='sep'> | </span>
<span class="share-social share-facebook"><a href="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F" class="button" title="Share on Facebook" data-url="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" target="_blank" rel="nofollow"><i></i><span>Share</span></a><span class="count"></span></span>
<span class='sep'> | </span>
<span class="share-social share-tweet"><a href="https://twitter.com/intent/tweet?original_referer=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F&source=tweetbutton&text=A+Data+Science+Lesson+from+Richard+Feynman&url=http%3A%2F%2Fwww.micfarris.com%2F%3Fp%3D1433&via=MicFarris" class="button" title="Tweet this Post" data-url="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" target="_blank" rel="nofollow"><i></i><span>Tweet</span></a><span class="count"></span></span>
<span class='sep'> | </span>
<span class="share-social share-linkedin"><a href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F&title=A+Data+Science+Lesson+from+Richard+Feynman&source=Get+Noticed%21+Theme" class="button" title="Share on LinkedIn" data-url="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" target="_blank" rel="nofollow"><i></i><span>Share</span></a><span class="count"></span></span>
<span class='sep'> | </span>
<span class="share-social share-googleplus"><a href="https://plus.google.com/share?hl=en-US&url=http%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F" class="button" title="Share on Google+" data-url="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/" target="_blank" rel="nofollow"><i></i><span>+1</span></a></span>
<span class='sep'> | </span>
<span class="share-print"><a href="http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/#print" class="button"><span>print</span></a></span>
<span class='sep'> | </span>
<span class="share-email"><a href="mailto:?subject=A%20Data%20Science%20Lesson%20from%20Richard%20Feynman&amp;body=Hey%2C%0D%0A%0D%0AI%20wanted%20to%20share%20this%20post%20by%20Mic%20Farris%20with%20you.%0D%0A%0D%0Ahttp%3A%2F%2Fwww.micfarris.com%2F2014%2F02%2Fa-data-science-lesson-from-richard-feynman%2F%0D%0A%0D%0AThanks%21" class="button"><span>email</span></a></span></aside>

	<div class="entry-footer">
		<div class="entry-date-wrap">
			<span class="posted-on">Posted on </span><time class="entry-date" datetime="2014-02-09T19:12:46+00:00" pubdate>Sunday, February 9, 2014</time>					</div>
		
				<span class="cat-links">
			Categories: <a href="http://www.micfarris.com/category/data-science/" rel="category tag">Data Science</a>, <a href="http://www.micfarris.com/category/more-science/" rel="category tag">More Science</a>		</span>
				
		<div class="disclosure">Disclosure of Material Connection: Some of the links in the post above are “affiliate links.” This means if you click on the link and purchase the item, I will receive an affiliate commission. Regardless, I only recommend products or services I use personally and believe will add value to my readers. I am disclosing this in accordance with the Federal Trade Commission’s <a href="http://www.access.gpo.gov/nara/cfr/waisidx_03/16cfr255_03.html" target="_blank">16 CFR, Part 255</a>: “Guides Concerning the Use of Endorsements and Testimonials in Advertising.”</div>	</div>
                        
</article>

					<nav role="navigation" id="nav-below" class="site-navigation post-navigation">
		<h1 class="assistive-text">Post navigation</h1>

	
		<div class="nav-previous"> <a href="http://www.micfarris.com/2013/09/10-things-to-know-when-hiring-data-scientists/" rel="prev"> <span class="meta-nav">&#11013;</span>  10 Things To Know When Hiring Data...  </a></div>		<div class="nav-next"><a href="http://www.micfarris.com/2014/10/the-fundamentals-of-data-science/" rel="next">The Fundamentals of Data Science <span class="meta-nav">&#10145;</span></a></div>
	
	</nav><!-- #nav-below -->
	
				<div id="respond" class="disqus-respond"></div><div id="comments-policy"><p>Please note: I reserve the right to delete comments that are offensive or off-topic.</p>
</div>
<div id="disqus_thread">
            <div id="dsq-content">


            <ul id="dsq-comments">
                    <li class="post pingback">
        <p>Pingback: <a href='http://accountsecurityguide.com/idg-contributor-network-enterprise-analytics-is-about-finding-better-problems/' rel='external nofollow' class='url'>IDG Contributor Network: Enterprise analytics is about finding better problems - Account Security Lockdown</a>()</p>
    </li>
    </li><!-- #comment-## -->
            </ul>


        </div>

    </div>

<script type="text/javascript">
var disqus_url = 'http://www.micfarris.com/2014/02/a-data-science-lesson-from-richard-feynman/';
var disqus_identifier = '1433 http://www.micfarris.com/?p=1433';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'micfarris';
var disqus_title = "A Data Science Lesson from Richard Feynman";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=1433';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>


			
			</div><!-- #content -->
		</div><!-- #primary .site-content -->

		<div id="secondary" class="sidebar widget-area" role="complementary">
			<aside id="widget_getnoticed_popularposts-2" class="widget widget_getnoticed_popularposts"><h3 class="widget-title">My Most Popular Posts</h3>			<div class="widget-content">
				<ul>					<li><img width="35" height="35" src="http://www.micfarris.com/wp-content/uploads/2013/01/Short-and-Tall-150x150.jpg" class="attachment-35x35 size-35x35 wp-post-image" alt="" /><a href="http://www.micfarris.com/2013/01/how-to-make-your-own-custom-url-shortener/" title="How to Make Your Own Custom URL Shortener">How to Make Your Own Custom URL Shortener</a></li>					<li><a href="http://www.micfarris.com/2011/09/data-science-defined/" title="Data Science Defined">Data Science Defined</a></li>					<li><a href="http://www.micfarris.com/2010/10/the-first-ever-cheesecake-playoffs/" title="The First Ever Cheesecake Playoffs">The First Ever Cheesecake Playoffs</a></li>					<li><a href="http://www.micfarris.com/2011/09/three-types-of-data-science-questions/" title="Three Types of Data Science Questions">Three Types of Data Science Questions</a></li>					<li><a href="http://www.micfarris.com/2009/06/persistence-that-lit-the-world/" title="Persistence That Lit the World">Persistence That Lit the World</a></li>				</ul>
			</div>
					</aside><aside id="widget_getnoticed_reachcounter-2" class="widget widget_getnoticed_reachcounter"><h3 class="widget-title">Total Reach</h3>			<div class="count"><span>
				4,779			</span></div>
</aside><aside id="widget_getnoticed_sociallist-2" class="widget widget_getnoticed_sociallist"><h3 class="widget-title">Let&#8217;s stay connected!</h3>	<div class="widget_sociallist">
		<ul>
		<li><a class="twitter" href="http://twitter.com/MicFarris" onclick="_gaq.push(['_trackPageview', '/outbound/widget_sociallist/sociallist/']);" target="_blank"><i></i>Follow me on Twitter</a></li><li><a class="facebook" href="http://www.facebook.com/micfarris" onclick="_gaq.push(['_trackPageview', '/outbound/widget_sociallist/sociallist/']);" target="_blank"><i></i>Like me on Facebook</a></li><li><a class="linkedin" href="http://www.linkedin.com/in/micfarris" onclick="_gaq.push(['_trackPageview', '/outbound/widget_sociallist/sociallist/']);" target="_blank"><i></i>Connect with me on LinkedIn</a></li><li><a class="googleplus" href="http://plus.google.com/113190000896646425022" onclick="_gaq.push(['_trackPageview', '/outbound/widget_sociallist/sociallist/']);" target="_blank"><i></i>Add me on Google+</a></li>		</ul>
	</div>
	</aside>		</div><!-- #secondary .widget-area -->

	</div></div><!-- #main -->

	
	<footer id="colophon" class="site-credits" role="contentinfo"><div class="innerwrap">

			<div class="site-info">
		<span class="copyright">©2017 - Mic Farris, All Rights Reserved.</span> <span class="poweredby">Powered by the <a href="http://getnoticedtheme.com/">Get Noticed! Theme</a>.</span>	</div>

		
	</div></footer>
	
</div><!-- #page .hfeed .site -->

</div><!-- .sitewrap -->

        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'micfarris';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        		<!-- Advertising Manager v3.5.3 (0.506 seconds.) -->
<script type='text/javascript' src='http://www.micfarris.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.micfarris.com/wp-includes/js/jquery/ui/effect-slide.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.micfarris.com/wp-content/themes/getnoticed/js/main.min.js?ver=20131027'></script>
<script type='text/javascript' src='http://www.micfarris.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>

</body>
</html>
